Lichtautomatik nachrüsten mal ganz allgemein

    • [Polo 6C]

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Lichtautomatik nachrüsten mal ganz allgemein

      Hi,

      gibt ja schon ein paar Threads Richtung Lichtautomatik.
      Habe mir heute das Nachrüstkit von x2car bestellt und werd hier mal meine Erfahrungen damit posten.
      Hier gibts das, ich meine, dass es neu ist. Lichtsensor VW Polo 6C Automatiklicht Lichtschalter, 120,99 € -

      Würde bzgl. dem Drehschalter empfehlen, mal einen Blick auf eBay und Co zu werfen, da hab ich meinen gebraucht für 35€ gekauft.
      Macht angeblich auch CH automatisch (getriggert auf 'Zündung aus' vermtl.), LH geht nicht, da es nicht erfahren kann, dass das Auto entriegelt wurde.

      Meld mich sobald das ganze ins Auto geht :)

      Viele Grüße!

      PS: Ach und allgemein, da es dem Zwischenstecker egal ist, ob am BCM jetz Halogen oder Xenon oder was auch immer kommt.

      Projekte, die nicht ausufern, waren keine richtigen Projekte.
      ANZEIGE
    • Soo, das Material ist da.

      Wichtigste Überlegung war: Wie bring ich den Lichtsensor vernünftig unter? Ich will nicht, dass irgendwo etwas rumhängt, wo es nicht hingehört. Eine hier vermutlich ein einziges Mal praktische Gegebenheit: Ich hab keine Klimaautomatik, ergo auch keinen Sonnensensor. Dieser sitzt genau zwischen den Luftausströmern für die Frontscheibe. (Bild 1, Deckel fehlt bereits)

      Der Blinddeckel lässt sich einfach heraushebeln und soll der ideale Spielplatz für den LDR sein. (Bilder 2 und 3)
      Die Fotodiode lässt sich leicht aus dem Gehäuse lösen, wenn man die klebefolie abzieht. Mittig ein loch in den Blinddeckel bohren und etwas Sekundenkleber. Die Kabel müssen ab. Hier markieren wies verbunden war. Die Fotodiode hat eine flache Seite im unteren Gehäuserand. An diese Seite gehört das gelbe Kabel. Material komplett. (Bild 4)

      Weitergehts ins Auto. Hat sich als recht schwierig herausgestellt ein Kabel da rein zu kriegen.. Man kommt nicht hin, weder von oben, noch von unten, noch von sonstwo, da der komplette Klimakasten Zwischen dem Innenraum und dem Sonnensensor ist. Was letzten Endes funktioniert hat: Ich habe ein etwas dickeres PVC Kabel genommen, durch das Sonnensensorloch nach links in den Kabelkanal geschoben und gestopft gestopft gestopft. Es hilft, das Kabel zu drehen, dann verkantet es sich nicht so stark. Nach einigem Hin und Her, habe ich das Kabel irgendwann zu sehen bekommen. Dazu habe ich etwa auf dem Fahrersitz gesessen, den Kopf auf dem Beifahrersitz liegen gehabt und und dann durch ein kleines Loch recht weit vorne drin tatsächlich mein Kabel entdeckt, davon gibts keider kein gutes Foto. Den Rest hat ein Greifer erledigt. (Bild 5) Schließlich war das Kabel dann im Radiokasten. (Bild 6) Von da gehts recht leicht Richtung Lichtschalter.
      Das dicke Kabel habe ich als Zugdraht verwendet um meine dünne, in Textilband eingewickelte Doppelleitung in den Radiokasten zu ziehen. Von dort gehts mit dem Kabelstrang aus Bild 5 erst Richtung sicherungskasten, dann am Relaishalter vorbei zum Lichtschalter.
      Es empfiehlt sich links an der Fahrertür den Deckel vom Armaturenbrett abzunehmen, der ist nur geclipst. I. A. ist die Verlegearbeti da recht einfach.

      Ich habe vor der Verkabelung einen kurzen Funktionstest gemacht. (Bild 7)
      Die Lichtautomatik funktioniert wunderbar - allerdings habe ich hier jetzt auch ein großes Problem.

      In keiner Kombination kann ich mit dem Adapter Nebelscheinwerfer oder Nebelschlussleuchte anschalten, weder mit Automatikmodi noch im manuellen Betrieb. Mit den Lichtschaltern ohne den Zwischenadapter funktioniert dies problemlos. Sowohl mit dem Originalen ohne "Auto" Position als auch mit dem neuen mit "Auto" Position. Aktuell liegt das Problem also am Zwischenstecker, der meine Nebelbeleuchtung nicht durchschalten will.

      Stehe in Kontakt mit x2car und schau mir das auch selbst nochmal an.

      Melde mich sobald es weitergeht. :D

      Zur Not wird hier nach der ESP-Geschichte der nächste Mikrocontroller in meinem Auto versenkt .....

      Dateien
      • bild1.jpg

        (162,15 kB, 39 mal heruntergeladen, zuletzt: )
      • bild2.jpg

        (255,71 kB, 31 mal heruntergeladen, zuletzt: )
      • bild3.jpg

        (113,33 kB, 28 mal heruntergeladen, zuletzt: )
      • bild4.jpg

        (241,15 kB, 37 mal heruntergeladen, zuletzt: )
      • bild5.jpg

        (177,69 kB, 34 mal heruntergeladen, zuletzt: )
      • bild6.jpg

        (110,4 kB, 34 mal heruntergeladen, zuletzt: )
      • bild7.jpg

        (114,2 kB, 33 mal heruntergeladen, zuletzt: )
      Projekte, die nicht ausufern, waren keine richtigen Projekte.
    • Nach aktuellem Stand erscheint es mir - in dieser Konstellation - nicht möglich, dass dieser Adapter an meinem Polo 6C funktioniert ?(

      Im Anhang ein Bild, das meine Gedanken verdeutlicht. Ich habe sowohl die Schaltkreise im VW Lichtschalter, als auch die an diesem Zwischenstecker, betreffend NSW / NSL reverse engineered.
      Heraus kommt dabei verifiziert etwas, das gar nicht funktionieren kann, aber im Einzelnen:


      Rechts im Bild habe ich den Nebel-Teil des Drehschalters aufgezeichnet.
      Position 1: NSW + NSL aus.
      Position 2: NSW an, NSL aus.
      Position 3: NSW + NSL an.
      Der Schaltplan ist nicht vollständig, da auch noch die wechselnde Bleuchtung der NSW Position (grün) des Schalters hier angreift, das ist an dieser Stelle aber nicht von Belang.

      Ich habe dies in meinem Auto ohne den Zwischenstecker nachgemessen.
      Am Pin 5 liegen immer 12V vom BCM an. Drehe ich den Lichtschalter auf Standlicht und ziehe ihn eine Raste heraus bricht die Spannung ein und es fließt vom Auto in den Schalter auf Pin 5 ein Strom von 0,8mA. Die Nebelscheinwerfer leuchten.
      Ziehe ich den Schalter auf die zweite Raste heraus fließt vom Auto in den Schalter auf Pin 5 ein Strom von 2mA. Nebelscheinwerfer und Nebelschlussleuchte leuchten.
      Ich gehe davon aus, dass die Regelgröße hier also der fließende Strom ist.

      Alle anderen Funktionen ("0", Auto, Standlicht, Abblendlicht) haben eine eigene Steuerleitung. Ist die Funktion aktiviert, liegen an der Leitung 12V an (vom Schalter geschaltet), ist sie es nicht, liegen 0V an. Das heißt stelle ich den Schalter auf Abblendlicht so liegen an Pin 1 12V an, an den restlichen genannten Steuerleitungen 0V usw.

      Genau dies kann der Zwischenadapter erzeugen. Sehen wir ihn uns an. S_PIN5 wird über eine Diode auf PIN5 Autoseite durchgeschleift. Stelle ich mir nun vor, der ganze Rest der Schaltung ist mal weg, so wird einfach nur das Steuersignal durchgereicht.
      Mit dem Spannungsteiler auf der rechten Seite kann der verbaute Mikrocontroller ( MCU ) erkennen welchen Zustand die entsprechende Steuerleitung hat (dies ist 5 Mal für alle genannten Kanäle vorhanden).
      Über die Transistorkonstruktion auf der linken Seite kann der MCU nach eigenem Gutdünken ausgehende Steuerleitungen richtung Auto aktiv setzen - der Sinn einer Lichtautomatik.

      Kommen wir nun aber zur Krux an der Geschichte. Wir erinnern uns, dass der Lichtschalter auf den Nebelpositionen einen Stromfluss vom Auto in den Schalter erzeugt und nicht durch eine Steuerleitung high/low geschaltet wird. Diese Konstruktion kann dieses Verhalten unmöglich emulieren oder weitergeben. Im Gegenteil, sie verhält sich genau so, wie die restlichen Kanäle.
      Es ist daher technisch nicht möglich, dass der Adapter mit meinem Auto funktioniert.

      Warum genau er für den Polo 6C angeboten wird ist mir schleierhaft.

      Warum VW generell diesen Unsinn betreibt verstehe ich auch nicht - zumal ein Pin (7) am Schalter nicht belegt ist. Man hätte hier genau gleich wie alle anderen Funktionen eine Steuerleitung für Nebelscheinwerfer und eine für Schlusslicht anlegen können.

      Ich kann den Adapter leider nicht zurückgeben, da ich ihn wie man sehen kann schon zurechtgeschnitten habe.

      Melde mich wenns Neues gibt :S

      Dateien
      • polo_schalter.png

        (66,11 kB, 28 mal heruntergeladen, zuletzt: )
      Projekte, die nicht ausufern, waren keine richtigen Projekte.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von nEmai ()

    • Soo lang ists her.

      Der x2car Support ist zwar ganz nett, konnte mir aber auch nicht wirklich weiterhelfen.
      Auch der Test dort, ob sie wirklich Mist verkaufen, steht noch aus.

      Was habe ich in der Zwischenzeit gemacht?
      Ich habe die einfache Lösung ergriffen, zu sehen im Anhang. Der Transistor kam raus, der Widerstand auch, die Diode auch und gebrückt (grün). Damit habe ich die NSW / NSL Leitung komplett von dem Modul entkoppelt.

      Da es theoretisch ohnehin nicht erlaubt ist, mit NSW zu fahren, wenn die Bedingungen es nicht erfordern, hab ich gesagt Automatik diesbezüglich ist egal. Die vorderen NSW können so nicht mehr automatisch mit dem Abblendlicht eingeschaltet werden. Wohl aber manuell, wenn ich den Schalter herausziehe. NSL ebenso. Für mich voll in Ordnung.

      Ansonsten habe ich es nun circa einen Monat getestet. Es ist ein bisschen schwer einzustellen, so dass es immer passt. Ich weiß aber auch nicht wie gut sich eine "ab Werk"-Automatik bei verschiedenen Bedingungen schlägt, da ich noch nie so viel mit sowas gefahren bin, um einen vergleichbaren Eindruck zu haben.

      Empfehlung?
      Weiß nicht. Funktional okay, nachdem man es umgebaut hat. Tut man das nicht, hat man keine Nebelbeluchtung mehr.
      Da es für mich nun tut werd ichs drin lassen.

      So viel dazu erst mal von meiner Seite.
      Sollten von irgendwem Fragen aufkommen, gerne melden :)

      Viele Grüße!

      Dateien
      • polo_schalter.png

        (72,78 kB, 18 mal heruntergeladen, zuletzt: )
      Projekte, die nicht ausufern, waren keine richtigen Projekte.
    • Nein, ich habs irgendwann aufgegeben, da ne Antwort zu bekommen.

      Aus meiner Sicht kann es definitiv nicht funktionieren, wie oben ausgeführt. Ich glaube auch nicht, dass das beim 6C ausstattungsabhängig ist.

      Insgesamt würde ich es auch nicht nochmal einbauen, da es nicht "so gut" funktioniert, wie es das in Autos mit Lichtautomatik ab Werk tut.

      Viele Grüße

      Projekte, die nicht ausufern, waren keine richtigen Projekte.
    • das wäre mir die Selbstbeteiligung wert. Das mach ich auf jeden Fall.

      Wird der Regensensor dann auch gehen?

      Was benötige ich dafür alles?

      Scheibe
      Regen/Lichtsensor
      Innenspiegel
      Kabelsatz
      Lichtschalter mit Automatik
      Codierung

      Noch was?

      Ihr habt nicht zufällig die Teilenummern?

      Mfg Matthias Knuhr

      ANZEIGE
    • Gemacht habe ich es noch nicht, aber mehrfach hier gelesen, dass es kein Problem ist.
      Ich halte es auch für recht einfach.

      Der Spiegel/Regen/Lichkomplex kommt mit folgenden Leitungswünschen:

      Abblendbarer Spiegel:
      - Signal Rückfahrleuchte
      - Plus via SC30
      - Masse

      Regen/Lichtsensor:
      - LIN-Bus T73c/15 am BCM
      - Plus via Sicherung SC53
      - Masse

      Also zusammengefasst Strom und LIN sowie Rückfahrleuchte.
      Wenn du dann noch nen Lichtschalter mit Automatik hast und hier und da bisschen codierst sollte das schnell erledigt sein.

      Aber dafür darfst du dir gern einen eigenen Thread machen ;):D

      Projekte, die nicht ausufern, waren keine richtigen Projekte.
    • Hallo,
      habe das Fahrzeug gerade abgeholt. Am Spiegel sieht es so aus, als ob ein Sensor verbaut ist oder die Vorbereitung da ist.
      Habe ich aufgrund der Klimatronic evtl wie beim Golf 7 hier einen Luftfeuchtesensor?
      Den könnte ich dann ja gegen einen Regensen, Licht und Feuchtesensor tauschen.

      Wie sieht das bei Euch aus?

      Mfg Matthias Knuhr

      Dateien

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von MatthiasKnuhr ()

    • nEmai schrieb:

      Nach aktuellem Stand erscheint es mir - in dieser Konstellation - nicht möglich, dass dieser Adapter an meinem Polo 6C funktioniert ?(

      Im Anhang ein Bild, das meine Gedanken verdeutlicht. Ich habe sowohl die Schaltkreise im VW Lichtschalter, als auch die an diesem Zwischenstecker, betreffend NSW / NSL reverse engineered.
      Heraus kommt dabei verifiziert etwas, das gar nicht funktionieren kann, aber im Einzelnen:


      Rechts im Bild habe ich den Nebel-Teil des Drehschalters aufgezeichnet.
      Position 1: NSW + NSL aus.
      Position 2: NSW an, NSL aus.
      Position 3: NSW + NSL an.
      Der Schaltplan ist nicht vollständig, da auch noch die wechselnde Bleuchtung der NSW Position (grün) des Schalters hier angreift, das ist an dieser Stelle aber nicht von Belang.

      Ich habe dies in meinem Auto ohne den Zwischenstecker nachgemessen.
      Am Pin 5 liegen immer 12V vom BCM an. Drehe ich den Lichtschalter auf Standlicht und ziehe ihn eine Raste heraus bricht die Spannung ein und es fließt vom Auto in den Schalter auf Pin 5 ein Strom von 0,8mA. Die Nebelscheinwerfer leuchten.
      Ziehe ich den Schalter auf die zweite Raste heraus fließt vom Auto in den Schalter auf Pin 5 ein Strom von 2mA. Nebelscheinwerfer und Nebelschlussleuchte leuchten.
      Ich gehe davon aus, dass die Regelgröße hier also der fließende Strom ist.

      Alle anderen Funktionen ("0", Auto, Standlicht, Abblendlicht) haben eine eigene Steuerleitung. Ist die Funktion aktiviert, liegen an der Leitung 12V an (vom Schalter geschaltet), ist sie es nicht, liegen 0V an. Das heißt stelle ich den Schalter auf Abblendlicht so liegen an Pin 1 12V an, an den restlichen genannten Steuerleitungen 0V usw.

      Genau dies kann der Zwischenadapter erzeugen. Sehen wir ihn uns an. S_PIN5 wird über eine Diode auf PIN5 Autoseite durchgeschleift. Stelle ich mir nun vor, der ganze Rest der Schaltung ist mal weg, so wird einfach nur das Steuersignal durchgereicht.
      Mit dem Spannungsteiler auf der rechten Seite kann der verbaute Mikrocontroller ( MCU ) erkennen welchen Zustand die entsprechende Steuerleitung hat (dies ist 5 Mal für alle genannten Kanäle vorhanden).
      Über die Transistorkonstruktion auf der linken Seite kann der MCU nach eigenem Gutdünken ausgehende Steuerleitungen richtung Auto aktiv setzen - der Sinn einer Lichtautomatik.

      Kommen wir nun aber zur Krux an der Geschichte. Wir erinnern uns, dass der Lichtschalter auf den Nebelpositionen einen Stromfluss vom Auto in den Schalter erzeugt und nicht durch eine Steuerleitung high/low geschaltet wird. Diese Konstruktion kann dieses Verhalten unmöglich emulieren oder weitergeben. Im Gegenteil, sie verhält sich genau so, wie die restlichen Kanäle.
      Es ist daher technisch nicht möglich, dass der Adapter mit meinem Auto funktioniert.

      Warum genau er für den Polo 6C angeboten wird ist mir schleierhaft.

      Warum VW generell diesen Unsinn betreibt verstehe ich auch nicht - zumal ein Pin (7) am Schalter nicht belegt ist. Man hätte hier genau gleich wie alle anderen Funktionen eine Steuerleitung für Nebelscheinwerfer und eine für Schlusslicht anlegen können.

      Ich kann den Adapter leider nicht zurückgeben, da ich ihn wie man sehen kann schon zurechtgeschnitten habe.

      Melde mich wenns Neues gibt :S
      An meinem Polo 6C funktioniert die Nebelschlussleuchte, ich habe den Auto Light Adapter jedoch im Herbst 2018 in China gekauft. Ich musste nur den Schwellwert, wenn das Abblendlicht eingeschaltet werden soll, heruntersetzen. Leider ist die englische Übersetzung der Anleitung kaum verständlich...

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von swiss007 ()